Backend for Autoviewer 2.02

I’ve been getting feedback from people that they are having trouble installing my Autoviewer backend script onto their web hosting servers. With Leff’s help we were able to find the pesty bug in the install script and can now release the 2.02 version of the script. Basically the new release is just like the earlier versions except the install script now comes with the “it works” feature and should thus be a breeze to install.

There were couple of reasons why the installer did not work right out of the box. Finding the bugs wasn’t an easy straight forward task since the descriptions of symptoms were somewhat vague and I didn’t have a reference environment available.

The first thing that came to my mind was that I had done the development on WAMP platform and moving from WAMP to LAMP often times requires some tinkering with things like making sure the ASCII files use the right encoding. This time my hunch failed me and problem was elsewhere.

In the end the crucial bit was that in a hurry to get this thing out there I had overwritten the install script with something from an older codebase. Consequently instead of the new SQL create statements the ones from old install script were there. Also the path to config file was wrong.

Anyways Leff came to rescue and did bit of detective work to find the root of the problem. Curing a diagnosed disease was pretty easy. Big thanks!

2 Responses to “Backend for Autoviewer 2.02”


  1. 1 fideocam April 26, 2009 at 7:13 pm

    Lots of people are also having trouble with some of the older PHP and SQL installations so I’m working on a 2.03 package that downgrades to more commonly available level.


  1. 1 Backend for Autoviewer 2.03 « Fideocam – The Blog Trackback on May 18, 2009 at 9:11 pm
Comments are currently closed.



Fideocam concept

Fideocam is a pioneer in automating video tools for personal experience capture.

Categ

Archives


%d bloggers like this: